The rerouting fix implemented by our data center engineers has been confirmed to allow our systems to connect to Microsoft. This incident is now resolved.
Our Data Center Engineers observed that Microsoft is having issues routing data and Azure/M365 is impacted. They have routed around the Microsoft outage. A fix has been implemented and our team will continue monitoring the results.
Posted Mar 03, 2025 - 11:24 MST
Investigating
Our CMS is currently experiencing connectivity issues when making requests to Microsoft services. This is impacting Sign in with Microsoft as well as retrieving calendar data. Our team is currently investigating the root cause and will provide more information as it becomes available.
Posted Mar 03, 2025 - 10:23 MST
This incident affected: Rally (Rally CMS, SchoolGuide App) and StaffConnect, Bus Status.