Email Delivery Delayed to Microsoft 365 / Outlook.com / Hotmail accounts

Incident Report for Rally

Resolved

Email messages generated by Rally CMS websites are no longer delayed when sent to Microsoft 365, Outlook.com, and Hotmail accounts.
Posted Mar 02, 2023 - 08:23 MST

Monitoring

We are aware that email messages generated by Rally CMS websites are being delayed when sent to Microsoft 365, Outlook.com, and Hotmail accounts. Delivery is taking up to an hour or more from the time the email is initially sent.

Please don't hesitate to reach out to our support team If you have any questions.
Posted Feb 28, 2023 - 12:07 MST
This incident affected: Rally (Rally CMS).