We’re happy to share that our scheduled maintenance is now complete — well ahead of schedule! What was planned as a 4-hour window wrapped up in 45 minutes.
Thanks for your patience as we continue working to provide a faster, more reliable experience.
— The Rally Team
Posted Jul 02, 2025 - 17:44 MDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2025 - 17:00 MDT
Scheduled
We will be performing scheduled maintenance to increase capacity and enhance overall system performance.
During this time, public-facing websites and apps are expected to remain largely unaffected. However, access to the CMS, control panels, and other internal systems may be temporarily unavailable.
We appreciate your understanding as we work to improve our infrastructure.
Posted May 26, 2025 - 14:55 MDT
This scheduled maintenance affected: Rally (Rally CMS, SchoolGuide App) and StaffConnect, Bus Status.