Website Connection Issues

Incident Report for Rally

Resolved

The connection issues have now been fully resolved. Thank you for your patience and understanding while our team worked to restore service.
Posted Aug 25, 2025 - 12:55 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2025 - 12:13 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 25, 2025 - 11:58 MDT

Investigating

We are receiving reports of increased connectivity issues. Websites may be unavailable for some users, or they may receive a 503 or 504 error.

Our team is currently investigating the issue and will provide updates once we have more information.

Thank you for your patience and understanding as we work to identify and respolve this issue.
Posted Aug 25, 2025 - 11:36 MDT
This incident affected: Rally (Rally CMS, SchoolGuide App) and StaffConnect, Bus Status.