Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 24, 2023 - 20:00 MDT
Update
We have rescheduled our maintenance window to take place this evening, on Tuesday, October 24th. We appreciate your patience as we work to enhance the performance, stability, and reliability of our systems.
Thank you for your understanding and ongoing support!
Posted Oct 24, 2023 - 09:23 MDT
Scheduled
We wanted to let you know that we'll be performing some planned system maintenance. During this time, you may experience temporary unavailability or see your websites and apps in maintenance mode. We appreciate your patience as we work to enhance the performance, stability, and reliability of our systems.
Thank you for your understanding and ongoing support!
Posted Oct 20, 2023 - 09:58 MDT
This scheduled maintenance affected: Rally (Rally CMS, SchoolGuide App) and StaffConnect, Bus Status.